Support

If you have a problem or need to report a bug please email : support@dsprobotics.com

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

My first VST

Post any examples or modules that you want to share here

My first VST

Postby Nickateenbeats » Fri Sep 14, 2018 5:28 am

Hey guys hows it going? Just wanted to share my first vst i made. I do have a few problems i would like to share.
1. When im testing the VST i can press multiple keys at once, after export it turns to mono.
2. The GUI keyboard does not play any keys when pressed.
3. Feel free to add anything to it. Collabs are always welcomed!



Also, Please do not take this and sell it or anything.

Moved to User Examples by moderator
Attachments
First Synth.fsm
(1.19 MiB) Downloaded 71 times
Nickateenbeats
 
Posts: 8
Joined: Tue Jul 24, 2018 11:32 pm

Re: My first VST

Postby Spogg » Fri Sep 14, 2018 8:02 am

Hi Nickateenbeats

I’ve had a quick look and here’s what I found:

In the MIDI module the max number of voices was set to 1. This means monophonic. You need to set this to maybe 32 for polyphonic or, even better, have a user selection.

Stereo clipper should be right at the end of the audio chain with all the mono module outputs going into it. This means the audio interface will never be overloaded.

The MIDI keyboard should be connected between the incoming MIDI input and the MIDI to poly module. In your schematic it was sending MIDI wirelessly to all the knobs and controls!


Suggestions:

It would be better I think to have an additional selector option for each of the 3 effects in the chain. The option would be to bypass with the selector prim, so if not required they don’t use CPU.

It’s more usual to have any reverb at the end of an effects chain, to give space to any sound you synthesise. But it’s your designer’s decision to make for how any routing is set up.

Good luck!

Spogg
User avatar
Spogg
 
Posts: 1857
Joined: Thu Nov 20, 2014 4:24 pm
Location: Birmingham, England

Re: My first VST

Postby Nickateenbeats » Sat Sep 15, 2018 1:17 am

Hey spogg, i followed all the instructions you provided and everything seems to be working fine. However, when playing more than 1 note at a time the audio starts to get a distorted sound to it. It only happens when the echo delay is turned on. I tried moving the delay but nothing seems to help.
Nickateenbeats
 
Posts: 8
Joined: Tue Jul 24, 2018 11:32 pm

Re: My first VST

Postby Spogg » Sat Sep 15, 2018 8:04 am

When you play more than 1 note you can get addition and subtraction from peaks and troughs in the waveforms. The peaks can be up to twice as high as a single note. So I would suggest you use a scope and see where the levels are too high. I think you’re getting clipping somewhere.

Good luck!

Spogg
User avatar
Spogg
 
Posts: 1857
Joined: Thu Nov 20, 2014 4:24 pm
Location: Birmingham, England


Return to User Examples

Who is online

Users browsing this forum: RJHollins and 15 guests