If you have a problem or need to report a bug please email :

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

Crustcrawler AX-12A Smart Arm+USB2Dynamixel+flowbotic

Discuss robotics applications using FlowStone here

Crustcrawler AX-12A Smart Arm+USB2Dynamixel+flowbotic

Postby adamsya » Tue Jul 10, 2012 8:49 am

Hi I am Adam..

I own 1 units crustcrawler Ax-12A arm robot + USB2Dynamixel + CM-700,

Alex Dirks CEO of Crustcrawler ask me to try the new flowbotic.. so I have download:

# Free trial flowstone V2
# Dynamixel Servo Test .fsm code
# Flowbotics Studio V1.27 (code only) & V1.21(exe & code)

To check the usb2dynamixel working, I connect all 7 motor to USB2Dynamixel and use dynamixal wizard software(roboplus). All the motor can move

First I try with Dynamixel_Servo.fsm but all dynamixel not moving. I dont know where to select COM port or baud rate setting..

Then I use Flowbotics Studio V1.27.. there is no EXE file, so I open the fsm file..
#No Arm found, I change to COM 3 but still no arm found.. the green indicator is not turn on..

Next I try Flowbotics Studio V1.21(code and EXE),
#still no arm found and no movement even after I change COM3 port..the green indicator is not turn on..

DId I miss any step? Could someone help me? thanks~
Posts: 2
Joined: Tue Jul 10, 2012 5:41 am

Re: Crustcrawler AX-12A Smart Arm+USB2Dynamixel+flowbotic

Postby DSP » Tue Jul 17, 2012 11:54 pm

Quite a few steps..

There is a test example especially for the CrustCrawler Arm here:

Only Flowbotics Studio V1.27 supports the CrustCrawler Arm and in order to compile it you will need a full FlowStone Pro license or at least an 18 Month free Trial (that you get with the Arm + FlowStone bundle).

If it says no Arm files found it means that you haven't installed it correctly. In the download there are four separate Arm files that setup the arms, these files should be in the same folder as the EXE (or in the FlowStone install Folder). Without these it will never work.

I've tried it all here and it works perfectly.
Posts: 150
Joined: Fri May 14, 2010 10:55 pm

Crustcrawler AX 12A Smart ArmUSB2Dynamixelflowbotic

Postby byronPeary » Sat May 11, 2019 11:06 pm

cool works great for me,Time lag, but that is to be expected, Good work.
User avatar
Posts: 2
Joined: Tue Apr 30, 2019 4:15 am
Location: Norway

Return to Robotics

Who is online

Users browsing this forum: No registered users and 1 guest